The next Courseware will unlikely be backwards compatible with BuddyPress <v.1.3

The codebase changed a lot, it got just better and a lot of time might be required to maintain some compatibility with older releases, which is not a good investment of my time 😐

Also with the next Courseware, you will likely ain't want to use an older version.
Btw, there's no need to worry about the data, it will require no changes!

Advertisements